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本製品（ソフトウェアを含む）は、外国為替および外国

貿易法で規定される規制貨物（または役務）に該当するこ

とがあります。 

その場合、日本国外へ輸出する場合には日本国政府
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点にご相談ください。 
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は し が き 

本書は、SX-Aurora TSUBASA システムの性能解析ツールである NEC Ftrace Viewer について説

明したものです。 

 

  



 

 

本書の対象読者 

本書は主に一般利用者およびプログラマを対象として書かれており、読者がFortranコンパイラ(nfort)、

Cコンパイラ(ncc)、C++コンパイラ(nc++)、NEC MPIの基本的な知識を有していることを前提として

います。 

本書の読み進め方 

本書は次の章から構成されています。表の右側の対象読者を参考にして読み進めてください。 

章 タイトル 内容 対象読者 

1 概要 NEC Ftrace Viewer の特長を説明  一般利用者 

プログラマ 

2 はじめてみよう NEC Ftrace Viewer を使ったチューニ

ング手順を説明 

一般利用者 

プログラマ 

3 基本的な操作 画面構成や基本的な操作方法を説明 一般利用者 

プログラマ 

4 性能情報の可視化 グラフ、テーブルの詳細を説明 一般利用者 

プログラマ 

5 トラブルシューティング NEC Ftrace Viewer 使用時に発生した

トラブルの解決方法について説明 

一般利用者 

プログラマ 

 

  



 

 

関連説明書 

本書に関連する説明書として次のものがあります。 

• Fortranコンパイラ(nfort)の説明 

Fortranコンパイラ ユーザーズガイド 

• Cコンパイラ(ncc)、C++コンパイラ(nc++)の説明 

C/C++コンパイラ ユーザーズガイド 

• NEC MPIの説明 

NEC MPIユーザーズガイド 

• FTRACEの説明 

PROGINF/FTRACE ユーザーズガイド 

• VEO の説明 

The Tutorial and API Reference of Alternative VE Offloading 

表記上の約束 

本書では次の表記規則を使用しています。 

• ハイフン( - )に続く太字の文字列 

コマンドのオプションを表します。 

• コマンド実行例のドル記号( $ ) 

bash(Bourne-Again シェル)のプロンプトを表します。 

• ncc/nc++/nfort/mpincc/mpinc++/mpinfort 

本書では、これらプログラムをコンパイル、およびリンクするコマンドをコンパイラと呼び

ます。 

• 大括弧( [  ] )で囲まれた文字列 

メニューまたはボタンを表します。例えば、[File]で"File"という名前のメニューまたはボタ

ンを表します。[File]→[Exit]の場合、"File"メニューの"Exit"サブメニューを表します。 
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 概要 

1.1 チューニング 

プログラムをより高速に、より効率的に実行できるようにプログラムを改善することをチューニン

グといいます。一般的には、実行時間が大きい箇所を改善することでプログラムを大きく高速化でき

ます。しかし、プログラムが複雑になるにしたがって、実行時間が大きい箇所の発見や実行時間が大き

い理由の判断は難しくなります。誤った箇所を誤った方法でチューニングしても効果はありません。

このため、チューニングを効率的に行うためには、支援ツールを使ってプログラムの性能情報を正確

に把握する必要があります。 

1.2 NEC Ftrace Viewer 

NEC Ftrace Viewer は、Fortran/C/C++プログラムのチューニングを支援する GUIツールです。性

能情報をグラフィカルに表示でき、主に以下のような特長を持ちます。 

• 簡易性能解析機能(ftrace 機能)による性能測定結果をグラフィカルに表示します。 

• 自動並列化機能、OpenMP、MPIを利用したプログラムに対応し、スレッド・MPIプロセス

ごとの実行時間、MPI プロセス間の通信時間を表示でき、性能ボトルネックやそれらのロー

ドインバランスを容易に把握できます。 

• 性能値に基づいた関数・スレッド・MPIプロセスの絞り込み表示や多彩なグラフ形式により、

シングルスレッドプログラムから数千プロセスに及ぶ MPIプログラムまで、様々なプログラ

ムの性能解析をサポートします。 
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 はじめてみよう 

2.1 チューニング手順 

NEC Ftrace Viewer を使ったチューニング作業は以下の手順になります。解析情報ファイルの確認

で NEC Ftrace Viewer を使って問題個所を把握し、プログラムを修正し、チューニング作業を繰り返

します。プログラムの性能が目標を達成したらチューニング完了です。 

(1) 性能測定用プログラムの作成 

(2) 性能測定用プログラムの実行と解析情報ファイルの採取 

(3) 解析情報ファイルの確認 

2.2 性能測定用プログラムの作成 

コンパイラに-ftrace を指定してプログラムをコンパイル・リンクし、性能測定用プログラムを作成

します。 

例 Fortranコンパイラ(nfort)の場合 

$ nfort -ftrace a.f90 

例 Cコンパイラ(ncc)の場合 

$ ncc -ftrace a.c 

例 C++コンパイラ(nc++)の場合 

$ nc++ -ftrace a.cc 

例 Fortranコンパイラ(nfort)用MPI シェルスクリプトの場合 

$ mpinfort -ftrace a.f90 
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例 Cコンパイラ(ncc)用MPIシェルスクリプトの場合 

$ mpincc -ftrace a.c 

例 C++コンパイラ(nc++)用MPIシェルスクリプトの場合 

$ mpinc++ -ftrace a.c 

2.3 性能測定用プログラムの実行と解析情報ファイルの採取 

性能測定用プログラムを実行し、解析情報ファイルを採取します。性能測定用プログラムは、通常の

プログラムと同じように実行できます。性能測定用プログラムは、プログラム終了時にプログラムが

実行されたディレクトリに解析情報ファイルを出力します。解析情報ファイルは、以下のファイル名

で、非 MPIプログラムの場合は一つ、MPIプログラムの場合は MPI プロセスの数だけ作成されます。 

• 非MPI プログラムの場合 

ftrace.out 

• MPIプログラムの場合 

ftrace.out.グループ ID.ランク番号 

グループ ID、ランク番号はそれぞれ NEC MPI の環境変数 MPIUNIVERSE、MPIRANK の

値 

例 非MPI プログラムの場合 

$ /opt/nec/ve/bin/ve_exec ./a.out (性能測定用プログラムの実行) 

$ ls ftrace.out 

ftrace.out 
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例 MPIプログラムの場合 

$ mpirun -np 4 /opt/nec/ve/bin/ve_exec ./a.out 

(性能測定用プログラムの実行) 

$ ls ftrace.out.* 

ftrace.out.0.0 ftrace.out.0.1 ftrace.out.0.2 ftrace.out.0.3 

2.4 解析情報ファイルの確認 

以下のコマンドのどちらかを実行し、NEC Ftrace Viewer を起動します。 

$ /opt/nec/ve/ftraceviewer/ftraceviewer 

$ /opt/nec/ve/ftraceviewer/ftraceviewer-c (Cロケール(LANG=C)で起動) 

NEC Ftrace Viewer が起動すると、以下の初期画面が表示されます。 
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画面上部のメニューバーから、測定プログラムに合わせて以下のようにメニューを選択し、解析情

報ファイルを読み込みます。 

• 非MPI プログラムの場合 

[File]→[Open File]を選択 

• MPIプログラムの場合 

[File]→[Open Directory]を選択 

注意 

VEO を使用したプログラムの場合は非 MPI プログラムと同様に[File]→[Open File]を選択して一つの解析情

報ファイルを読み込んでください。 

ファイル選択ダイアログが文字化けする場合、ご利用のロケールに対応したフォントパッケージをインスト

ールして NEC Ftrace Viewerを起動するか、/opt/nec/ve/ftraceviewer/ftraceviewer-cコマンドを使用して Cロケ

ール(LANG=C)で NEC Ftrace Viewerを起動してください。 

ファイルの読み込みが完了すると、解析結果のグラフが画面の上部分に、テーブルが画面の下部分

に表示されます。画面構成や基本的な操作方法については第 3 章を、グラフとテーブルの詳細につい

ては第 4 章を参照してください。NEC Ftrace Viewer を終了する場合、[File]→[Exit]を選択します。 
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 基本的な操作 

3.1 画面構成 

解析情報ファイルを読み込むと、以下の要素で構成された画面が表示されます。 

(1) ウィンドウタイトル 

(2) メニュー 

(3) グラフ表示領域 

(4) テーブル表示領域 

 

3.2 読み込んだ解析情報ファイルの確認 

ウィンドウタイトルに読み込んだ解析情報ファイル、または解析情報ファイルを含むディレクトリ

のパス、読み込んだ解析情報ファイルの個数が表示されます。 

 

 

 

1 
2 

3 

4 
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• [File]→[Open File]から一つの解析情報ファイルを読み込んだ場合 

指定された解析情報ファイルのパスが表示されます。 

 

• [File]→[Open File]で複数の解析情報ファイルを読み込んだ場合 

最初の解析情報ファイルまでのパスと最後の解析情報ファイルのファイル名が"~"で連結さ

れて表示されます。 

 

• [File]→[Open Directory]で読み込んだ場合 

指定したディレクトリまでのパスが表示されます。 

 

3.3 新しいグラフ・テーブルを開く 

新しいグラフを開く場合、[Chart]のサブメニューを選択します。新しいグラフはグラフ表示領域に

新しいタブで追加されます。各グラフの詳細は「4.3 グラフ」を参照してください。 

 

新しいテーブルを開く場合、[Table]→[Open Profile Tree Table]を選択します。新しいテーブルはテ

ーブル表示領域に新しいタブで追加されます。テーブルの詳細は「4.4 テーブル」を参照してください。 
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3.4 グラフ・テーブルの配置の操作 

NEC Ftrace Viewer はウィンドウの中に一つ以上の領域(ページ)があり、ページの中にグラフとテ

ーブルのビューがタブで表示されています。ページとビューを操作することでグラフとテーブルの配

置を変更できます。ビューとページは以下の要素で構成されます。 

(1) ページ 

(2) タブ 

(3) 閉じるボタン 

(4) 最小化ボタン 

(5) 最大化ボタン 

(6) 復元ボタン 

(7) 高速ビューボタン 
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3.4.1 ビューの移動 

ビューはページ間を移動できます。タブをページの境界にドラッグ＆ドロップするとページが分割

され、複数のビューが同時に表示されます。 

 

元のページへ戻す場合、元のページ上のタブの前後にドラッグ＆ドロップします。ビューが一つも

存在しないページは削除されます。 
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さらに、タブをウィンドウの外にドラッグ＆ドロップすると別のウィンドウで表示されます。元の

ウィンドウへ戻す場合、タブを元のページ上のタブの前後にドラッグ＆ドロップします。 

 

3.4.2 ページの最小化・最大化 

最小化ボタンをクリックすると、ページがウィンドウの右もしくは下に格納(最小化)されます。最小

化されたページを元に戻すにはページの復元ボタンを押します。最大化ボタンをクリックすると、他

のページがすべて最小化されます。また、タブをダブルクリックすることでもページを最大化・最小化

できます。 
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3.4.3 高速ビューでの表示 

最小化したページにはビューごとに高速ビューボタンが表示されます。高速ビューボタンをクリッ

クすると、ビューが表示中のページにオーバーラップして表示されます。 

 

3.4.4 ビューを閉じる 

タブの閉じるボタンをクリックします。閉じたビューはメニューから再度開くことができます。 

3.5 新しい解析情報ファイルの読み込み 

[File]→[Open File]、または[File]→[Open Directory]を選択すると、以前に開いていた解析情報ファ

イルをすべて閉じて、新しい解析情報ファイルを読み込みます。 

補足 

以前に開いていた解析情報ファイルを閉じたくない場合、NEC Ftrace Viewerをもう一つ起動し、そちらで新

しい解析情報ファイルを読み込んでください。 
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3.5.1 ファイルを指定した読み込み 

[File]→[Open File]からダイアログを開き、ファイルを指定します。既定で「ftrace.out*」でフィル

タされます。ファイル名を変更している場合は、フィルタを「*.*」などに変更してください。 

補足 

Ctrl キーを押しながらファイルをクリックすると、複数のファイルが選択できます。また、Shift キーを押し

ながらファイルをクリックすると、クリックした範囲のファイルが選択できます。 

注意 

 

非 MPI プログラムの解析情報ファイルと MPI プログラムの解析情報ファイルを同時に指定すると読み込み

に失敗します。また、VEOを使用したプログラムの解析情報ファイルを複数同時に読み込むと不正な結果が表

示される場合があります。 

 

3.5.2 ディレクトリを指定した読み込み 

[File]→[Open Directory]からダイアログを開き、ディレクトリを指定します。指定したディレクト

リの直下にある解析情報ファイルをすべて読み込みます。 

注意 

指定したディレクトリに非 MPI プログラムの解析情報ファイルと MPI プログラムの解析情報ファイルの両

方が含まれる場合、読み込みに失敗します。 
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3.6 解析情報ファイルを指定した起動 

NEC Ftrace Viewer の起動コマンドに-f オプションで解析情報ファイルを指定すると、起動と同時

に解析情報ファイルを読み込みます。 

例 非MPI プログラムの解析情報ファイルの場合 

$ /opt/nec/ve/bin/ftraceviewer/ftraceviewer -f ftrace.out 

例 MPIプログラムの解析情報ファイルの場合 

$ /opt/nec/ve/bin/ftraceviewer/ftraceviewer -f ftrace.out.* 
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 性能情報の可視化 

4.1 可視化要素 

NEC Ftrace Viewer は、ftrace 機能で採取した以下の要素を可視化します。 

• プログラムの形態 

− シングルスレッド実行 

− コンパイラの自動並列化・OpenMPを用いた共有メモリ型並列(マルチスレッド)実行 

− MPIを用いた分散メモリ型並列(マルチプロセス)実行 

− 共有メモリ型並列実行と分散メモリ型並列実行を組み合わせたハイブリッド並列実行 

• 実行コンテキスト 

− 共有メモリ型並列実行のスレッド 

− 分散メモリ型並列実行のMPIプロセス 

− 分散メモリ型並列実行のMPIユニバースに含まれる MPIプロセスの集合 

− ハイブリッド並列実行のスレッド 

− ハイブリッド並列実行のMPIプロセス 

− ハイブリッド並列実行のMPIユニバースに含まれる MPIプロセスの集合 

• 実行コード 

− 関数、サブルーチン 

− コンパイラの自動並列化機能・OpenMP機能により並列化された区間 

− ftrace 機能によるユーザリージョン 
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4.2 性能項目 

NEC Ftrace Viewer は、ftrace 機能と同等の性能項目の可視化をサポートします。 

(*1) VE30で実行したプログラムの解析情報ファイルを指定した場合に出力 

性能項目 単位 説明 

FREQUENCY - 関数の呼出し回数 

EXCLUSIVE TIME 秒 関数の実行に要した EXCLUSIVE な CPU 時

間 

AVER.TIME ミリ秒 関数の１回の実行に要した EXCLUSIVE な

CPU時間の平均 

MOPS - MOPS 値 

MFLOPS - MFLOPS値 

V.OP.RATIO % ベクトル演算率 

AVER.V.LEN - 平均ベクトル長 

VECTOR TIME 秒 ベクトル命令実行時間 

L1CACHE MISS 秒 L1キャッシュミス時間 

CPU PORT CONF 秒 CPUポート競合時間 

LD L3 HIT ELEM.% % ロード命令で L3キャッシュにヒットした要素

の割合 (*1) 

VLD LLC HIT ELEM.% % ベクトルロード命令で LLCにヒットした要素

の割合 

ELAPSED TIME 秒 経過時間 

MPI COMM.TIME 秒 MPI通信の送受信に要した経過時間 

MPI IDLE TIME 秒 MPI通信の通信を行うまでの待ち時間、およ

び同期待ちに要した経過時間 

MPI COMM.TIME/ELAPSED % 関数内での経過時間に対する

MPI COMM.TIMEの比率 
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性能項目 単位 説明 

MPI IDLE TIME/ELAPSED % 関数内での経過時間に対する

MPI IDLE.TIME の比率 

MPI AVER.LEN キロバイト 

(1024換算) 

MPI通信 1回当たりの平均通信量 

MPI COUNT - MPI通信回数 

MPI TOTAL LEN メガバイト 

(1024換算) 

MPI通信の通信量 
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環境変数 VE_PERF_MODE に VECTOR-MEM を指定して採取した解析情報ファイルの場合、

L1CACHE MISS、CPU PORT CONF、VLD LLC HIT E.%の代わりに以下の項目が利用できます。 

(*1) 100以上の値は切り捨て 

(*2) VE30で実行したプログラムの解析情報ファイルを指定した場合に出力 

(*3) VE10、VE10E、VE20で実行したプログラムの解析情報ファイルを指定した場合に出力 

性能項目 単位 説明 

L1ICACHE MISS 秒 L1 命令キャッシュミス時間 

L1OCACHE MISS 秒 L1 オペランドキャッシュミス時間 

L2CACHE MISS 秒 L2 キャッシュミス時間 

LD L3 HIT ELEM.% % ロード命令で L3キャッシュにヒットした要素の割合 

(*2) 

VLD LLC HIT ELEM.% % ベクトルロード命令で LLCにヒットした要素の割合 

(*2) 

REQ. B/F - ロード命令とストア命令に指定されたバイト数から算出

した B/F (*1) 

REQ. ST B/F - ストア命令に指定されたバイト数から算出した B/F (*1) 

REQ. LD B/F - ロード命令に指定されたバイト数から算出した B/F (*1) 

ACT. LD B/F - ロード命令により実際に発生したメモリアクセスのバイ

ト数から算出した B/F (*1) (*2) 

ACT. VLD B/F - ベクトルロード命令により実際に発生したメモリアクセ

スのバイト数から算出した B/F (*1) (*3) 

FLOP COUNT - 浮動小数点データ実行要素数 

FMA ELEM. - FMA 命令実行要素数 
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4.3 グラフ 

グラフを用いると、実行コードまたは実行コンテキストごとの性能値を様々な形式で可視化するこ

とができます。利用できるグラフ形式は以下のとおりです。 

• 実行コードごとに性能値を表示するグラフ 

実行時間の長い関数を発見するために利用します。 

− Function Metric Chart 

− Function Breakdown Chart (自動並列化・OpenMP プログラムのみ) 

− Function Statistics Chart 

• 実行コンテキストごとに性能値を表示するグラフ 

MPIプロセス間やスレッド間のロードインバランスを発見するために利用します。 

− Process Metric Chart 

− Process Breakdown Chart 

− MPI Communication Chart (MPI プログラムのみ) 

• 実行コンテキストの性能値分布を表示するグラフ 

大量の MPIプロセスから性能の悪い MPI プロセスを発見するために利用します。 

− Process Histogram (MPI プログラムのみ) 

グラフでは、特に指定がない限り、実行コードを「関数(Function)」、実行コンテキストを「プロセ

ス(Process)」とも呼びます。 



 

20 

4.3.1 基本的な操作 

実行コンテキストごとに性能値を表示するグラフでは棒グラフの幅を調整することができます。

Ctrl キーを押しながらマウスホイールを上に回した場合、棒グラフが拡大表示され、マウスホイール

を下に回した場合、棒グラフが縮小表示されます。 

 

グラフに集計・表示する性能項目、実行コード、実行コンテキストはメニューから変更します。詳細

は、「4.3.9 性能項目の選択」、「4.3.10 プロセスの選択」、「4.3.11 関数の選択」を参照してください。 
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4.3.2 Function Metric Chart 

関数ごとに、性能値を色つきの棒グラフと折れ線グラフで表示します。棒グラフの軸は上に、折れ線

グラフの軸は下に表示されます。折れ線グラフで表示する性能項目は任意の種類選択できます。 

 

棒グラフの色は選択した関数の中で、最大値を赤、中間を緑、最小値を青でグラデーション表示しま

す。下記のグラフでは do_upper と subst1 を選択しているため、subst1が最小値となり、青色で表示

されます。 

 

一方、下記のグラフでは do_upper から compl$1 を選択しているため、compl$1 が最小値となり、

青色で表示されます。 
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4.3.3 Function Breakdown Chart 

関数ごとに、各スレッドの性能値を色分けした棒グラフで表示します。例えば、下記の例では、1ス

レッドで実行されている関数 subst1は 1色で表示され、4スレッドで実行されている関数 compl$1は

スレッドごとに 4 色に色分けされて表示されています。 

また、Function Metrics Chart と同様に、折れ線グラフで複数の性能値を同時に表示できます。 

注意 

棒グラフには、積み上げが可能な性能項目のみ選択できます。 
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4.3.4 Function Statistics Chart 

関数ごとに、プロセスの性能値の最大・最小・平均・標準偏差を表示します。 

 

棒グラフは下記の様に、左端を基準にして、青から緑に変わる箇所が最小値、緑から赤に変わる箇所

が平均値、赤色の右端が最大値を表しています。 

 

Min Avg Max 
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赤色の部分が大きい場合、関数を実行したいくつかのプロセス・スレッドの性能値が突出していま

す。例えば、下記のグラフの場合、compu$1は 0番目のスレッドのみ実行時間が大きいため、赤色部

分が大きく表示されています。 

 

折れ線グラフは性能値の標準偏差を表しています。値が大きい場合、プロセス間の性能値のばらつ

きが大きいことを表しています。 

注意 

関数の並べ替えは、Function Metrics Chart と同様に、集計に含まれるプロセス全体の性能値で行われます。

このため、下記の様に最大値が突出している関数が順番に並んで無いように見える場合があります。 
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4.3.5 Process Metrics Chart 

指定した関数に対して、プロセスごとの性能値を色つきの棒グラフと折れ線グラフで表示します。

棒グラフの軸は左に、折れ線グラフの軸は右に表示されます。折れ線グラフで表示する性能項目は任

意の種類選択できます。 

棒グラフの色は選択したプロセスの中で、最大値を赤、中間を緑、最小値を青でグラデーション表示

します。下記の例では、MPIランク番号が 9の MPI プロセスが最大値、MPI ランク番号が 31の MPI

プロセスが最小値となります。 
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4.3.6 Process Breakdown Chart 

MPI プロセスごとに性能値の大きな関数を下から順に積み上げて表示します。性能値が小さな関数

は灰色でまとめられます。 

 

個別に積み上げる関数の指定と積み上げ順の変更は[Function Selection]で行います。チェックが入

った関数が上から順番に選択され、個別にグラフに積み上げられます。チェックが入っていない関数

は Other Functions として一つにまとめられます。詳細な操作法は「4.3.11 関数の選択」を参照して

ください。 

 

注意 

このグラフでは、積み上げが可能な性能項目のみ選択できます。 

 

 

Other Functions 

Stacked individually 
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4.3.7 MPI Communication Chart 

指定した関数に対して、MPIプロセスごとの経過時間・MPI通信時間・MPI 通信待ち時間を表示し

ます。 

 

棒グラフは下記の様に、下端を基準にして、赤から緑への変わり目が MPI 通信待ち時間、緑から青

への変わり目が MPI 通信時間、青色の上端が経過時間を表しています。 

注意 

MPI通信時間は MPI通信待ち時間を含むため、待ち時間を含まない MPI通信処理時間は、緑色の範囲になり

ます。同様に、経過時間は MPI通信時間を含むため、ユーザの計算コードの実行など MPI通信以外の処理にか

かった時間は青色の範囲になります。 

 

ELAPSED TIME 

MPI COMM.TIME 

MPI IDLE TIME 
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4.3.8 Process Histogram 

MPIプロセスの性能分布をヒストグラムで表示します。横軸は性能値、縦軸はその性能値を取るMPI

プロセスの個数を表しています。ヒストグラムにフォーカスを合わせると MPI ランク番号がポップア

ップします。 

 

4.3.9 性能項目の選択 

[Metric Selection]から選択ダイアログを開き、Main Metric から棒グラフで表示する性能項目を、

Sub Metrics から折れ線グラフで表示する性能項目を選択します。 
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折れ線グラフには、Sub Metricsリストの中のチェック済みの性能項目が上から順に表示されます。

折れ線グラフの表示順を変更する場合、リストの項目をドラッグ＆ドロップで並べ替えてください。 

 

4.3.10 プロセスの選択 

表示や集計を行うプロセスを変更する場合、[Process Selection]から選択ダイアログを開きます。 

 

集計に含む範囲は、MPI ユニバース、MPIプロセス、スレッドの順に絞り込みます。選択可能な絞

り込みは以下のとおりです。 

注意 

非 MPIプログラムの場合でも、絞り込み対象として MPIユニバースと MPIプロセスが表示されます。非 MPI

プログラムの場合、MPIユニバース番号は 0、MPIランク番号は 0で固定されます。 

スレッド番号は OpenMPまたは自動並列スレッドを識別するための 0から始まる数字です。 
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絞り込み対象 絞り込み方法 集計に含む範囲 

MPI Universe All selection 全MPI ユニバース 

MPIユニバース番

号 

環境変数 MPIUNIVERSE の値が選択した値と同

じMPI ユニバース 

MPI Process All selection 選択した MPI ユニバース配下の全 MPI プロセス 

Custom selection 選択した MPI ユニバース配下の任意の複数MPI

プロセス 

MPIランク番号 選択した MPI ユニバース配下で、環境変数

MPIRANK の値が選択した値と同じMPIプロセ

ス 

Thread All selection 選択した MPI プロセス配下の全スレッド 

Custom selection 選択した MPI プロセス配下の任意の複数スレッド 

スレッド番号 選択した MPI プロセス配下で、選択したスレッド

番号を持つスレッド 

 

任意の複数プロセスで絞り込みを行う場合、Custom Selection を選択します。Custom Selection で

は、画面下部のテキストエリアに入力された番号を持つ MPI プロセスもしくはスレッドが集計に含ま

れます。 

Start/End/Stride を使って、テキストエリアに範囲を指定して入力できます。 

• Start テキストエリアに入力する最小の番号を指定します。 

• End テキストエリアに入力する最大の番号を指定します。 

• Stride Startから End までの間で指定した数だけスキップしながら番号を選択します。 

例えば、"Start"に 8、"End"に 24、"Stride"に 2 を指定した場合、8 から 24 の間の偶数がテキスト

エリアに入力されます。 

スライダで Start と End を指定することも可能です。スライダの左側のつまみが Start の番号、右

側のつまみが End の番号を示しています。つまみを前後させて Startと End の番号を増減します。ス

ライダの青色部分をドラッグすると Startと End の番号が同時に増減します。 
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MPIプロセスもしくはスレッドの表示順を並べ替える場合、Sort by metric を使います。プルダウ

ンメニューから性能項目を選択すると、テキストエリアの番号が選択した性能項目の性能値の大きい

順に並べ替えられます。PROC.NAMEを選択すると番号順に並べ替えられます。反対順に並べ替える

場合、Reverse をチェックしてください。 

 

4.3.11 関数の選択 

表示や集計を行う関数を変更する場合、[Function Selection]から選択ダイアログを開きます。 
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リストの中のチェック済みの関数が上から順に選択されグラフに表示されます。コンパイラの自動

並列化機能、または OpenMP により並列化された関数は「$数値」が付加されて出力されます。関数

の表示順を変更する場合、リストの項目をドラッグ＆ドロップで並べ替えてください。 

 

性能項目に基づいて関数の表示順を並べ替える場合、Sort by metricを使います。プルダウンメニュ

ーから性能項目を選択すると、リストの関数が選択した性能項目の性能値の大きい順に並べ替えられ

ます。PROC.NAMEを選択すると関数の名前が辞書順に並べ替えられます。反対順に並べ替える場合、

Reverse をチェックしてください。 

条件を満たす関数のみを選択する場合、Selectもしくは Select top of metric を使います。Selectの

場合、プルダウンメニューから下記の条件を指定することで、その条件を満たす関数が選択されます。

Select top of metric の場合、性能項目と選択する個数を指定することで、性能値が大きい関数が指定

した個数分選択されます。 

条件 選択される関数 

All すべての関数 

Executed one or more times 1回以上実行された関数 

Executed by some threads 複数のスレッドで実行された関数 

Executed by some MPI process 複数の MPIプロセスで実行された関数 

None すべての関数の選択を解除する 

 



 

33 

4.3.12 性能項目・関数の配色の変更 

以下のグラフでは性能項目・関数の配色を変更できます。 

• 折れ線グラフで表示された性能項目の配色 

Function Metrics Chart、Function Breakdown Chart、Process Metrics Chart 

• 関数の配色 

Process Breakdown Chart、Process Histogram 

配色を変更する場合、[Color Selection]から選択ダイアログを開きます。関数の配色の変更はすべて

のグラフに反映されます。 

注意 

配色の変更はグラフが再描画されたタイミングで反映されます。表示中の他のグラフに配色の変更が反映さ

れない場合、そのグラフをリサイズして再描画させてください。 
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4.3.13 グラフの画像出力 

グラフを右クリックし[Save as]を選択すると、表示されているグラフを PNG形式で保存できます。 

注意 

保存される画像ファイルには、画面に表示されている範囲のみ含まれます。グラフをスクロールしないと見

えない範囲は画像ファイルに含まれません。 

 

4.4 テーブル 

テーブルを用いると関数、ユーザリージョン、MPI ユニバース、MPIプロセス、スレッドの全性能

項目の性能値を一覧表示できます。テーブルの要素はドリルダウンできます。例えば、ハイブリッド並

列の場合、関数を展開してその関数を実行した MPI プロセスの個々の性能値を表示でき、さらに MPI

プロセスを展開して個々のスレッドの性能値を表示できます。 

テーブルでは、以下 2種類の表示形式が利用できます。 

• Function Table 

関数、サブルーチン、並列区間の性能値を一覧表示します。 

• User Region Table 

ユーザリージョンの性能値を一覧表示します。 
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4.4.1 基本的な操作 

表示項目をドリルダウンする場合、PROC.NAME 列のツリー展開アイコンをクリックします。 

 

性能値で並べ替えを行う場合、対象の性能項目のテーブルヘッダをクリックします。 
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性能項目の表示位置を変更する場合、対象の性能項目のヘッダをマウスでドラッグ＆ドロップして

位置を入れ替えます。 

 

テーブルに表示する性能項目、ドリルダウンの方法はメニューより変更できます。詳細は 4.4.4、4.4.5

を参照してください。 
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4.4.2 Function Table 

関数、サブルーチン、並列化された区間の性能値を一覧表示します。既定で関数・サブルーチン・並

列区間、MPIユニバース、MPIプロセス、スレッドの順番でドリルダウンできます。ドリルダウンの

順番は変更できます。詳細は「4.4.5 ドリルダウン方法の選択」を参照してください。 

いくつかの性能項目では、セル内に性能値がグラフで表示されます。 

• 積み上げが可能な性能項目の場合、Total行との比率を青(0%)から赤(100%)で表示 

• 割合を計算している性能項目の場合、その値が青(0%)から赤(100%)で表示 

注意 

MOPSや MFLOPSなど、上記に該当しない性能項目ではグラフは表示されません。 
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4.4.3 User Region Table 

ユーザリージョンの性能値を一覧表示します。ユーザリージョン、MPIユニバース、MPIプロセス、

スレッドの順番でドリルダウンできます。 

 

4.4.4 性能項目の選択・並べ替え 

[Table Setting]から設定ダイアログを開きます。テーブルに表示したくない性能項目があれば、チェ

ックボックスを外してください。性能項目はマウスでドラッグ＆ドロップして並べ替えできます。 
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4.4.5 ドリルダウン方法の選択 

[Table Setting]から設定ダイアログを開きます。Function Table を選択すると、テーブルの表示が

Function Table に切り替わります。ドリルダウンの順番を以下から選択してください。 

• Function > MPI Process > Thread order 

関数、MPIユニバース、MPIプロセス、スレッドの順にドリルダウンします。 

• MPI Process > Function > Thread order 

MPIユニバース、MPIプロセス、関数、スレッドの順にドリルダウンします。 

• MPI Process > Thread > Function order 

MPIユニバース、MPIプロセス、スレッド、関数の順にドリルダウンします。 

User Region Table を選択すると、テーブルの表示が User Region Table に切り替わります。 
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 トラブルシューティング 

本章では、NEC Ftrace Viewer 使用時に発生したトラブルの解決方法について説明します。 

 

1. NEC Ftrace Viewer が起動しない 

ログに以下のエラーが出力される場合、X11 転送で NEC Ftrace Viewer を起動しようとして失敗し

ています。他の GUIアプリケーションで X11転送が利用できることをご確認ください。 

!MESSAGE Application error 

!STACK 1 

org.eclipse.swt.SWTError: No more handles [gtk_init_check() failed] 

 

2. ファイル選択ダイアログやディレクトリ選択ダイアログが文字化けする 

ご利用のロケールに対応したフォントがインストールされていません。ご利用のロケールに対応し

たフォントパッケージをインストールしてールして NEC Ftrace Viewer を起動するか、

/opt/nec/ve/ftraceviewer/ftraceviewer-c コマンドを使用して C ロケール(LANG=C)で NEC Ftrace 

Viewer を起動してください。 

 

3. 解析情報ファイルの読み込みに失敗する、または、期待した結果が表示されない 

NEC Ftrace Viewer は、1回の非 MPIプログラム実行が出力した 1つの解析情報ファイルの読み込

み、または、1回の MPI プログラム実行が出力した 1つ以上の解析情報ファイルの読み込みをサポー

トします。また、以下の解析情報ファイルの読み込みはサポートしていません。これらの場合、解析情

報ファイルをサポート範囲で分けて別々に読み込ませてください。 

• 非MPI プログラムと MPI プログラムの解析情報ファイルの同時読み込み 

• VEO を使用したプログラムの複数の解析情報ファイルの読み込み 

• 種類の異なる VE で実行された MPI プロセスにより出力された解析情報ファイルの同時

読み込み 
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• 環境変数 VE_PERF_MODE の値が MPI プロセスごとに異なる場合、これらの MPI プロ

セスが出力した解析情報ファイルの同時読み込み 

 

4. NEC Ftrace Viewer の動作が遅い 

NEC Ftrace Viewer は既定の最大メモリ使用量を 2GiBに制限しています。このため、大量の解析

情報ファイルを読み込んだ場合、メモリが不足し動作が遅くなる場合があります。NEC Ftrace Viewer

のメモリ使用量は起動時のコマンドラインオプションで指定可能です。例えば、最大メモリ使用量を

10GiB まで拡大する場合、コマンドラインオプションの最後に「-vmargs -Xmx10G」を追加します。 

注意 

「-vmargs」およびそれ以降のオプションは必ずコマンドラインの最後に追加してください。そうしない場合、

コマンドラインオプションが誤って解釈され起動に失敗します。 

$ /opt/nec/ve/ftraceviewer/ftraceviewer -f ftrace.out.* -vmargs -Xmx10G 
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付録A 改訂履歴 

版数 発行日 変更内容 

初 版 2018 年 2 月 初版 

第 2 版 2020 年 1 月  4.2 性能項目を追加 

第 3 版 2021年 12月  付録 Bを更新 

第 4 版 2022年 11月  2.4 解析情報ファイルの確認を更新 

 3.5 新しい解析情報ファイルの読み込みを更新 

第 5 版 2023 年 3 月  4.2 性能項目を更新 

 5章 トラブルシューティングを追加 

 付録 Bを更新 
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付録B 商標・ライセンス 

 

• Eclipse は、Eclipse Foundation の登録商標です。 

• その他、記載されている会社名、製品名は、各社の登録商標または商標です。 

 

NEC Ftrace Viewer に含まれるソフトウェアとそのライセンスは以下の通りです。 

ソフトウェア ライセンス 

JFreeChart 

http://www.jfree.org/index.html 

LGPL Version 2.1 

JCommon 

http://www.jfree.org/index.html 

LGPL Version 2.1 

PngEncoder 

http://catcode.com/pngencoder/ 

LGPL Version 2.1 

Guava 

https://code.google.com/p/guava-libraries/ 

Apache License 2.0 

Eclipse RCP 

https://www.eclipse.org/ 

Eclipse Public License Version 1.0 

OSGi Materials 

https://www.osgi.org 

Apache License 2.0 

Jakarta Commons Collections 

https://commons.apache.org/proper/commons-collections/ 

Apache License 2.0 

ICU4J 

http://site.icu-project.org/ 

ICU License 

Independent JPEG Group's JPEG software release 6b 

http://ijg.org/ 

独自ライセンス 
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ソフトウェア ライセンス 

PuTTY 0.58 

http://www.chiark.greenend.org.uk/~sgtatham/putty/ 

MIT License 

Gnome 

(Eclipse RCP の“Gnome Binding”に含まれる) 

http://www.gnome.org/ 

LGPL Version 2.1 

GTK+  

(Eclipse RCP の“GTK+ Binding”に含まれる) 

http://www.gtk.org/ 

LGPL Version 2.1 

WebKitGTK+ 

(Eclipse RCP の“WebKitGTK+ Binding”に含まれる) 

http://webkitgtk.org/ 

LGPL Version 2.1 

libsoup 

(Eclipse RCP の“WebKitGTK+ Binding”に含まれる) 

http://www.gnome.org/ 

LGPL Version 2.1 

WebKit JavaScriptCore 

(Eclipse RCP の“WebKitGTK+ Binding”に含まれる) 

http://webkit.org/ 

BSD License 

Mozilla 

(Eclipse RCP の“Mozilla Binding”に含まれる) 

http://www.mozilla.org/ 

Mozilla Public License Version 1.1 

XULRunner 1.9 

(Eclipse RCP の“Mozilla Binding”に含まれる) 

http://www.mozilla.org/ 

Mozilla Public License Version 1.1 

Cairo 

(Eclipse RCP の“Cairo Binding”に含まれる) 

http://cairographics.org/ 

Mozilla Public License Version 1.1 

Cairo for Linux 

(Eclipse RCP の“Cairo Library”に含まれる) 

http://cairographics.org/ 

Mozilla Public License Version 1.1 
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ソフトウェア ライセンス 

pixman 0.1.6 

(Eclipse RCP の“Cairo Library”に含まれる) 

http://www.pixman.org/ 

独自ライセンス 

W3C DTDs 

http://www.w3.org/ 

W3C Software Notice and License 

NEC Ftrace Viewer は Eclipse RCPによる Eclipse プラグインで構成されており、各プラグインに

上記のソフトウェアの一部またはすべて、または派生物が含まれます。各プラグイン(Eclipse RCP)、

および、それらに含まれるソフトウェアのライセンス情報は、NEC Ftrace Viewer の起動後、[Help]

→[About]→[Installation Details]→[Plug-ins]タブからプラグインを選択し[Legal Info]ボタンを押す

ことで、ウェブブラウザ(firefox)で参照できます。また、/opt/nec/ve/ftraceviewer/plugins/<プラグイン

ID>_<バージョン>.jar ファイル、または/opt/nec/ve/ftraceviewer/plugins/<プラグイン ID>_<バージ

ョン>ディレクトリに配置された about.html からもライセンス情報を参照できます。これらのソフト

ウェアに関連するソースコードは、ライセンスに従い、/opt/nec/ve/ftraceviewer/plugins/<プラグイン

ID>.source_<バージョン>.jar ファイル、または /opt/nec/ve/ftraceviewer/plugins/<プラグイン

ID>.source_<バージョン>ディレクトリに配置されています。ライセンスとソースコードに関する詳細

は各プラグインのライセンス情報をご参照ください。 

注意 

新しいライセンス情報ページが表示されない場合、ウェブブラウザを一度終了してから再表示してください。 
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